読者です 読者をやめる 読者になる 読者になる

よかろうもん!

アプリからインフラまで幅広くこなすいまどきのクラウドエンジニアが記す技術ブログ

`require': no such file to load -- ec2/amitools/bundle (LoadError)

RubyEnterpriseEditionのrubyを利用してEC2のAMIのバックアップをしようとした時に出力されたエラー。

/usr/lib/ruby/site_ruby/ec2/amitools/bundlevol.rb:11:in `require': no such file to load -- ec2/amitools/bundle (LoadError)

Rubyのライブラリがきちんと読めていないようなので、以下のようにRUBYLIBにパスを追加してロードできるようにしてあげましょう。

export RUBYLIB=$RUBYLIB:/usr/lib/ruby/site_ruby